[Besvare]Hvorfor driller min Ubiquiti USG - Det var en fejl på unifi controlleren!

Alt om software, sikkerhed, kryptering m.m. Spørg og der er sikkert en der kan hjælpe.
Besvar
Brugeravatar
Kleth
This member is
This member is
Indlæg: 4555
Tilmeldt: 27. mar 2013, 15:20
Interesser: Jage,Skyde,Ammo&Historie
Geografisk sted: Nordsjælland
Has thanked: 807 times
Been thanked: 534 times

[Besvare]Hvorfor driller min Ubiquiti USG - Det var en fejl på unifi controlleren!

Indlæg af Kleth » 19. apr 2019, 19:13

Nu har jeg godt nok brugt megen tid på det :evil: Ubiquiti :mad: jeg ved så at flere af jer anvender Ubiquiti så jeg håber at kunne få lidt råd
Topologien er

Kode: Vælg alt

[ISP Router](LAN)	-	(WAN1)[USG]	-	(LAN1)[Unmanaged Switch]	-	UNIFI controller (Raspberry Pi V1)
											-	UAP (AP AC LR)
Alle komponenter skulle køre med seneste version og seneste firmware og jeg kan pinge i mellem dem.
Screenshot at 2019-04-19 16-51-29.jpg
Screenshot at 2019-04-19 16-51-29.jpg (7.19 KiB) Vist 2745 gange
48EF24AF-9BB6-4EAD-A241-71C5B531B6D5.jpeg
48EF24AF-9BB6-4EAD-A241-71C5B531B6D5.jpeg (69.83 KiB) Vist 2730 gange
ISP'ens router kører med DHCP

Min udfordring er at jeg kan sagtens få controlleren (192.168.1.6) til at se og adoptere UAP
Screenshot at 2019-04-19 16-42-06_.jpg
, men uanset hvad jeg har gjort kan jeg ikke få lov at se USG (Ubiquiti Security Gateway ) og jeg har oven i købet fulgt vejledningen :shock: når jeg ikke kan se den under devices kan jeg jo heller ikke adoptere den.
Controlleren kører på en Raspberry Pi V1.

Flere skriver at man skal bruge CLI på USG, så det prøvede jeg også

Kode: Vælg alt

ssh ubnt@192.168.1.1
.
mca-cli
set-inform http://192.168.1.6:8080/inform
(så både med og uden exit og reboot)
Netværksindstillinger på USG - Uden internet
Screenshot at 2019-04-19 16-46-26_.png
Netværksindstillingerne på controlleren
Screenshot at 2019-04-19 16-42-51.jpg
Jeg er overbevist om at jeg overser et eller andet helt banalt, hvis jeg ikke har set mig blind på netværkskonfiguration, og jeg er endnu ikke familiær med Ubiquiti økosystemet :help:
Nogle bud på hvad jeg gør forkert :what:
Senest rettet af Kleth 21. apr 2019, 09:29, rettet i alt 3 gange.
“Another visitor! Stay a while; stay forever!”

KenP
Silver Member
Silver Member
Indlæg: 347
Tilmeldt: 18. nov 2013, 22:01
Interesser: Skydning
Geografisk sted: Sjælland
Has thanked: 12 times
Been thanked: 33 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af KenP » 19. apr 2019, 19:39

Du har lagt nyeste firmware på USG ikke?

Inform skal normalt køres 2 gange.

Men har USG ikke normalt default IP på 192.168.0.1... (vist så noget med man skal direkte i USG først for at ændre LAN IP, for at få det skiftet.

KenP
Silver Member
Silver Member
Indlæg: 347
Tilmeldt: 18. nov 2013, 22:01
Interesser: Skydning
Geografisk sted: Sjælland
Has thanked: 12 times
Been thanked: 33 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af KenP » 19. apr 2019, 19:41

Drop det sidste det havde du fikset.

Brugeravatar
Kleth
This member is
This member is
Indlæg: 4555
Tilmeldt: 27. mar 2013, 15:20
Interesser: Jage,Skyde,Ammo&Historie
Geografisk sted: Nordsjælland
Has thanked: 807 times
Been thanked: 534 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af Kleth » 19. apr 2019, 19:46

KenP skrev:
19. apr 2019, 19:39
Du har lagt nyeste firmware på USG ikke?

Inform skal normalt køres 2 gange.

Men har USG ikke normalt default IP på 192.168.0.1... (vist så noget med man skal direkte i USG først for at ændre LAN IP, for at få det skiftet.
Jo, jeg startede med 30-30-30 reset, og opdaterede USGs firmware til seneste version over SSH.
Jeg har ikke sat IP, men måske jeg skulle prøve 30-30-30 reset igen og se hvad den defaulter til.
Min fallback er at slette og resette ALT, men jeg vil hellere vide hvad der er løsningen og lære end at bruge XX antal minutter på at starte forfra og ende med samme resultat :wall:
“Another visitor! Stay a while; stay forever!”

KenP
Silver Member
Silver Member
Indlæg: 347
Tilmeldt: 18. nov 2013, 22:01
Interesser: Skydning
Geografisk sted: Sjælland
Has thanked: 12 times
Been thanked: 33 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af KenP » 19. apr 2019, 20:10

Fejl fundet...

Dit netværk skal være 192.168.1.0/24

Du har 1.1/24

https://help.ubnt.com/hc/en-us/articles ... ng-Network

Non ikke det er den

(Har ikke USG, men kun switche og accesspoints på mit, har dog så også nogle familiemedlemmers accesspoints switche kørende på min controller)

Rednex
Bronze Member
Bronze Member
Indlæg: 127
Tilmeldt: 10. mar 2016, 09:20
Interesser: Skydning og IT
Geografisk sted: Ølstykke
Has thanked: 28 times
Been thanked: 35 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af Rednex » 19. apr 2019, 21:23

Ikke at det er til megen hjælp, men jeg synes det hele ser rigtigt ud, så det burde bare virke.

Du kan evt. checke om USG'en sender data til controlleren ved at køre denne på Raspberry:

Kode: Vælg alt

sudo tcpdump -ni eth0 host 192.168.1.1 and port 8080
Det kan være at netkortet hedder ens160 i stedet for eth0.

Hvis der ikke kommer noget kan du prøve at reboote USG'en - så burde den forsøge at få fat i controlleren igen når den starter op.

EDIT: Hvis det går helt i spunk, så smid mig lige en PB. Jeg mistænker at vi bor rimelig tæt på hinanden, så jeg kan evt. svinge forbi og give en hånd med.

Brugeravatar
Kleth
This member is
This member is
Indlæg: 4555
Tilmeldt: 27. mar 2013, 15:20
Interesser: Jage,Skyde,Ammo&Historie
Geografisk sted: Nordsjælland
Has thanked: 807 times
Been thanked: 534 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af Kleth » 19. apr 2019, 21:59

Takker! Jeg vender tilbage, når jeg får prøvet det af senere imorgen :thumbup:
For en sikkerhedsskyld fik USG’en 30-30-30 reset, så jeg har et kendt udgangspunkt og så skal jeg bare have controlleren, USG og switch i spil - færre bevægelige dele.

@Rednex takker! Det er også en god ide at lure på TCP-trafikken, det var slet ikke faldet mig ind endnu.
“Another visitor! Stay a while; stay forever!”

JRexA
This member is
This member is
Indlæg: 5445
Tilmeldt: 5. jan 2007, 18:58
Interesser: Våben, Pistolskydning, Jagt
Geografisk sted: Nuuk, Grønland
Has thanked: 258 times
Been thanked: 572 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af JRexA » 20. apr 2019, 01:25

Jeg kan se, at du har kørt "Set-inform" på din USG (Set-Inform http://192.168.1.6:8080/inform)
Når ting ligger, på samme netværkssegment(her 192.168.1.0/24), så bør det fungere, med default indstillingen (set-inform http://unifi:8080/inform)

Er din Kontroller en CloudKey, eller Windows/Linux Software?
Hvis det er software, er der så en local Firewall på maskinen(Ex. Windows FireWall), og er der åbnet for port 8080 fra 192.168.1.1 i denne?

Kan det være fordi du har sat din CloudKey/Controller til kun at køre HTTPS?

En detalje: Du har et DHCP Range, der starter med 192.168.1.6 og din CloudKey/Controller har IP 192.168.1.6
Jeg HADER at køre DHCP, på den slags udstyr. Jeg kører ALTID, med fast IP
Du risikerer, at starter du udstyret, i en forkert rækkefølge, så vil din CloudKey/Controller ikke få IP 192.168.1.6

Har du checket ARP(arp -a) fra din USG, efter at have pinget 192.168.1.6?
Og får du den korrekte MAC Adresse?
Skyttehilsen fra Nuuk, Grønland
Jesper Rex

Brugeravatar
Kleth
This member is
This member is
Indlæg: 4555
Tilmeldt: 27. mar 2013, 15:20
Interesser: Jage,Skyde,Ammo&Historie
Geografisk sted: Nordsjælland
Has thanked: 807 times
Been thanked: 534 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af Kleth » 20. apr 2019, 06:16

JRexA skrev:
20. apr 2019, 01:25
Jeg kan se, at du har kørt "Set-inform" på din USG (Set-Inform http://192.168.1.6:8080/inform)
Når ting ligger, på samme netværkssegment(her 192.168.1.0/24), så bør det fungere, med default indstillingen (set-inform http://unifi:8080/inform)
Jeg prøvede at kalde default URL’en fra browser og der fik jeg en fejl, hvorfor jeg netop skiftede til at kalde direkte på IP, hvor der ikke kom fejl.
JRexA skrev:
20. apr 2019, 01:25
Er din Kontroller en CloudKey, eller Windows/Linux Software?
Hvis det er software, er der så en local Firewall på maskinen(Ex. Windows FireWall), og er der åbnet for port 8080 fra 192.168.1.1 i denne?
Jeg kører controlleren på Raspberry Pi V1 og port 8080 burde være åben, spørgsmålet er måske i virkeligheden om der måske er en anden service der i forvejen kører på 8080. Det er værd at se på :thumbup:

JRexA skrev:
20. apr 2019, 01:25
Kan det være fordi du har sat din CloudKey/Controller til kun at køre HTTPS?
Jeg har prøvet med både set-inform på både 8080 og 8443, som jeg har sat controlleren til at køre på og jeg får ikke fejl på nogen af portene.
JRexA skrev:
20. apr 2019, 01:25
En detalje: Du har et DHCP Range, der starter med 192.168.1.6 og din CloudKey/Controller har IP 192.168.1.6
Jeg HADER at køre DHCP, på den slags udstyr. Jeg kører ALTID, med fast IP
Du risikerer, at starter du udstyret, i en forkert rækkefølge, så vil din CloudKey/Controller ikke få IP 192.168.1.6
:thumbup: Jeg plejer at køre med både og, ved at lave DHCP reservationer til mine faste IP adresser (det gør jeg på et andet fysisk netværkssegment styret af en LRT224), men det har jeg endnu ikke fundet ud af mellem controlleren og USG endnu. USG har en fin oversigt over tildelte IP-adresser og controlleren fik den samme hver gang. Jeg har et mønster for hvordan jeg tildeler IP-adresser men det er ikke relevant før jeg har passeret den nuværende hurdle.
JRexA skrev:
20. apr 2019, 01:25
Har du checket ARP(arp -a) fra din USG, efter at have pinget 192.168.1.6?
Og får du den korrekte MAC Adresse?
Det kommer på listen af analytiske tiltag :thumbup:
“Another visitor! Stay a while; stay forever!”

Brugeravatar
Kleth
This member is
This member is
Indlæg: 4555
Tilmeldt: 27. mar 2013, 15:20
Interesser: Jage,Skyde,Ammo&Historie
Geografisk sted: Nordsjælland
Has thanked: 807 times
Been thanked: 534 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af Kleth » 20. apr 2019, 20:11

Aftenens analytiske tiltag flaskede sig ikke
Jeg havde 30-30-30 resat USG og udelukkende forbundet laptop til LAN1
Screenshot at 2019-04-20 17-09-04.jpg


Jeg satte Unifi controlleren på og forbandt unmanaged switch
Screenshot at 2019-04-20 17-16-58.jpg
USG tildelte Raspberry Pi V1 192.168.1.6 igen :smile:

Min SOHO USG har ikke ARP kommando :smile: , så jeg gik i loggen i stedet
Screenshot at 2019-04-20 17-56-49.jpg
Screenshot at 2019-04-20 17-56-49.jpg (15.55 KiB) Vist 2585 gange
Jeg fandt controllerens log og tailede den og sendte inform requests fra browseren
Screenshot at 2019-04-20 19-27-30.png
Screenshot at 2019-04-20 19-27-30.png (27.1 KiB) Vist 2585 gange
De blev identificeret som inform requests, men uden indhold, så man kan tilsyneladende sende inform requests både krypteret og ukrypteret.
Requests med set-inform fra USG dukkede ikke op i loggen.
tcpdump -ni eth0 host 192.168.1.1 and port 8080 på Raspberry Pi V1 viste at der går data fra 192.168.1.1 til 192.168.1.6 på port 8080 ved set-inform http://192.168.1.6:8080/inform - og jeg prøvede også port 8443 og der flød også data. Alt kan pinge mellem hinanden og der kan SSH'es mellem noderne og MAC-adresserne passer med IP-adresserne på tværs af komponenterne.Og jeg har sendt 15-20 set-inform http://192.168.1.6:8080/inform i streg og det samme bagefter med set-inform https://192.168.1.6:8443/inform - Og der sker nul og niks på controlleren.
Jeg har slået alt IPS, IDS m.v. fra

Jeg tror der er noget fisket i controlleren, så jeg vil prøve at installere lidt mere potent HW med Unifi controlleren - Ellers ender jeg nok med at skulle bide i det sure æble og købe en cloud key :nolisten:
“Another visitor! Stay a while; stay forever!”

KenP
Silver Member
Silver Member
Indlæg: 347
Tilmeldt: 18. nov 2013, 22:01
Interesser: Skydning
Geografisk sted: Sjælland
Has thanked: 12 times
Been thanked: 33 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af KenP » 20. apr 2019, 20:52

Du skulle vel ikke have haft controller indstalleret på din egen PC...

For man kan se ud fra din log, at den forsøger at forbinde til 192.168.1.8

Edit: ellers ændre ip på din rasperry til 8 ;-) også flyt din egen Lenovo til en anden.. (bare for at se om den så vil være med)

Brugeravatar
Kleth
This member is
This member is
Indlæg: 4555
Tilmeldt: 27. mar 2013, 15:20
Interesser: Jage,Skyde,Ammo&Historie
Geografisk sted: Nordsjælland
Has thanked: 807 times
Been thanked: 534 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af Kleth » 20. apr 2019, 22:29

KenP skrev:
20. apr 2019, 20:52
Du skulle vel ikke have haft controller indstalleret på din egen PC...

For man kan se ud fra din log, at den forsøger at forbinde til 192.168.1.8

Edit: ellers ændre ip på din rasperry til 8 ;-) også flyt din egen Lenovo til en anden.. (bare for at se om den så vil være med)
Lenovoen leger kun med i det omfang at den er browseren, som jeg bl.a. har lavet set-inform fra for at se hvad der sker i loggen og derfor optræder den i loggen, såvel som at jeg også anvender den til SSH-klient og til at tilgå og konfigurere web-ui.

Men jeg tænker at rydde op på Lenovoen og installere Unifi controlleren direkte på den i stedet for Raspberry Pi V1, for man skal hugge en hæl og klippe en tå for at få controlleren til at køre på Raspberry Pi V1 og den er laaaangsom sammenlignet med Lenovoen.
Senest rettet af Kleth 20. apr 2019, 22:39, rettet i alt 2 gange.
“Another visitor! Stay a while; stay forever!”

KenP
Silver Member
Silver Member
Indlæg: 347
Tilmeldt: 18. nov 2013, 22:01
Interesser: Skydning
Geografisk sted: Sjælland
Has thanked: 12 times
Been thanked: 33 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af KenP » 20. apr 2019, 22:37

Har ikke selv en pi... men køre alt mit på en N40L, og har gjort det i 6 på på Windows homeserver (først v1 og siden på whs2011)

Brugeravatar
Kleth
This member is
This member is
Indlæg: 4555
Tilmeldt: 27. mar 2013, 15:20
Interesser: Jage,Skyde,Ammo&Historie
Geografisk sted: Nordsjælland
Has thanked: 807 times
Been thanked: 534 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af Kleth » 20. apr 2019, 22:44

KenP skrev:
20. apr 2019, 22:37
Har ikke selv en pi... men køre alt mit på en N40L, og har gjort det i 6 på på Windows homeserver (først v1 og siden på whs2011)
Hvis jeg ikke får det til at skralde-an på Lenovoen, så banker jeg måske noget free-tier op på Azure eller AWS, men ud over min arbejds-laptop og min ældste søns skole-PC så haver vi ikke Windows i huset; ChromeOS, Linux og Android dækker langt de fleste behov.

Måske der er en Docker-container med Unifi?!?
Det er værd at undersøge :thumbup:
“Another visitor! Stay a while; stay forever!”

KenP
Silver Member
Silver Member
Indlæg: 347
Tilmeldt: 18. nov 2013, 22:01
Interesser: Skydning
Geografisk sted: Sjælland
Has thanked: 12 times
Been thanked: 33 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af KenP » 20. apr 2019, 23:32

Kleth skrev:
20. apr 2019, 22:44
KenP skrev:
20. apr 2019, 22:37
Har ikke selv en pi... men køre alt mit på en N40L, og har gjort det i 6 på på Windows homeserver (først v1 og siden på whs2011)
Hvis jeg ikke får det til at skralde-an på Lenovoen, så banker jeg måske noget free-tier op på Azure eller AWS, men ud over min arbejds-laptop og min ældste søns skole-PC så haver vi ikke Windows i huset; ChromeOS, Linux og Android dækker langt de fleste behov.

Måske der er en Docker-container med Unifi?!?
Det er værd at undersøge :thumbup:
Der er en docker container til unifi ;-)

Rednex
Bronze Member
Bronze Member
Indlæg: 127
Tilmeldt: 10. mar 2016, 09:20
Interesser: Skydning og IT
Geografisk sted: Ølstykke
Has thanked: 28 times
Been thanked: 35 times

Re: [Spørgsmål]Hvorfor driller min Ubiquiti USG - Kan ikke ses på controlleren

Indlæg af Rednex » 21. apr 2019, 09:32

Controlleren kører fint på en af de små maskiner i Azure - der har jeg min egen kørende. Jeg har dog opgraderet maskinen en smule, for ellers tager det en krig når man skal installere updates.

Hvis man husker at stoppe UniFi servicen inden man installerer updates, så går det nogenlunde.

Brugeravatar
Kleth
This member is
This member is
Indlæg: 4555
Tilmeldt: 27. mar 2013, 15:20
Interesser: Jage,Skyde,Ammo&Historie
Geografisk sted: Nordsjælland
Has thanked: 807 times
Been thanked: 534 times

Re: [Besvare]Hvorfor driller min Ubiquiti USG - Det var en fejl på unifi controlleren!

Indlæg af Kleth » 21. apr 2019, 09:39

Jeg fandt et installations-script, der ordnede det hele for mig på min Lenovo Laptop.
https://community.ubnt.com/t5/UniFi-Wir ... -p/2375150

Og det gav meget hurtigt resultat :rock:
Screenshot at 2019-04-21 09-08-47.png
Screenshot at 2019-04-21 09-08-47.png (25.56 KiB) Vist 2516 gange
Helt uden at pille-rode-rage på USG'en
Screenshot at 2019-04-21 09-12-19.png
Det er mig så en gåde, hvordan funktionaliteten kunne være delvis og at der ikke kom fejl . . . Det er den sværeste type fejl at diagnosticere :angry:
Tak for hjælpen, jeg kom 360 om problemet ved jeres hjælp :thumbup: så jeg kunne finde root-cause.

Nu er udfordringen så at jeg ikke gider have bundet Unifi controlleren til familie-laptoppen for tid og evighed :impatient:
- Måske jeg skulle have en ny raspberry v3
“Another visitor! Stay a while; stay forever!”

Rednex
Bronze Member
Bronze Member
Indlæg: 127
Tilmeldt: 10. mar 2016, 09:20
Interesser: Skydning og IT
Geografisk sted: Ølstykke
Has thanked: 28 times
Been thanked: 35 times

Re: [Besvare]Hvorfor driller min Ubiquiti USG - Det var en fejl på unifi controlleren!

Indlæg af Rednex » 21. apr 2019, 12:36

Fedt at du fik hul igennem! :DancingBanana:

Du behøver strengt taget kun controlleren når du vil lave ændringer. Ellers kører hele setuppet fint uden.

Brugeravatar
Kleth
This member is
This member is
Indlæg: 4555
Tilmeldt: 27. mar 2013, 15:20
Interesser: Jage,Skyde,Ammo&Historie
Geografisk sted: Nordsjælland
Has thanked: 807 times
Been thanked: 534 times

Re: [Besvare]Hvorfor driller min Ubiquiti USG - Det var en fejl på unifi controlleren!

Indlæg af Kleth » 20. maj 2019, 10:43

En mindre opdatering.
Jeg installerede Unifi på en Raspberry Pi V3 B, der har 1GB ram. Vejledningen jeg fulgte er her
https://community.ubnt.com/t5/UniFi-Rou ... -p/2470231
Det spiller fuldt ud og jeg skulle ikke udføre hacks som jeg skulle med Raspberry Pi V1 omkring CosmoDB.
Men nu er alle devices adopterede :numberone:

Jeg har ikke fået sat Pi-Hole op endnu, men det er tiltalende ud over at RPi så skal være operationel hele tiden. Mere om Pi-Hole
https://blog.cryptoaustralia.org.au/why ... r-pi-hole/
“Another visitor! Stay a while; stay forever!”

Rednex
Bronze Member
Bronze Member
Indlæg: 127
Tilmeldt: 10. mar 2016, 09:20
Interesser: Skydning og IT
Geografisk sted: Ølstykke
Has thanked: 28 times
Been thanked: 35 times

Re: [Besvare]Hvorfor driller min Ubiquiti USG - Det var en fejl på unifi controlleren!

Indlæg af Rednex » 20. maj 2019, 19:28

Kleth skrev:
20. maj 2019, 10:43
Jeg har ikke fået sat Pi-Hole op endnu, men det er tiltalende ud over at RPi så skal være operationel hele tiden. Mere om Pi-Hole
https://blog.cryptoaustralia.org.au/why ... r-pi-hole/
Jeg kører også med Pi-Hole, og den er jeg rigtig glad for. Jeg er dog lidt forsigtig med hvornår jeg opdaterer den, for det er sket flere gange at det ikke er lykkes i første hug, hvorefter man står uden DNS. Og man får altså ikke mange bonuspoint for at lægge DNS ned i en eller flere timer i løbet af aftenen.

Sørg for at dnsmasq er slået fra, da Pi-Hole kommer med sin egen version af den.

Brugeravatar
Kleth
This member is
This member is
Indlæg: 4555
Tilmeldt: 27. mar 2013, 15:20
Interesser: Jage,Skyde,Ammo&Historie
Geografisk sted: Nordsjælland
Has thanked: 807 times
Been thanked: 534 times

Re: [Besvare]Hvorfor driller min Ubiquiti USG - Det var en fejl på unifi controlleren!

Indlæg af Kleth » 20. maj 2019, 22:07

Rednex skrev:
20. maj 2019, 19:28
Kleth skrev:
20. maj 2019, 10:43
Jeg har ikke fået sat Pi-Hole op endnu, men det er tiltalende ud over at RPi så skal være operationel hele tiden. Mere om Pi-Hole
https://blog.cryptoaustralia.org.au/why ... r-pi-hole/
Jeg kører også med Pi-Hole, og den er jeg rigtig glad for. Jeg er dog lidt forsigtig med hvornår jeg opdaterer den, for det er sket flere gange at det ikke er lykkes i første hug, hvorefter man står uden DNS. Og man får altså ikke mange bonuspoint for at lægge DNS ned i en eller flere timer i løbet af aftenen.

Sørg for at dnsmasq er slået fra, da Pi-Hole kommer med sin egen version af den.
Godt tip om dnsmasq :thumbup:
Hvis jeg sætter controlleren til Pi-Hole som primær DNS og OpenDNS som sekundær DNS, så falder den vel direkte over OpenDNS såfremt Pi-Hole ikke svarer som DNS?!?

Iøvrigt så er Pi-Hole vældigt let at sætte op; jeg tænker også på muligheden at lægge noget OpenVPN server på :biggrin:
“Another visitor! Stay a while; stay forever!”

Rednex
Bronze Member
Bronze Member
Indlæg: 127
Tilmeldt: 10. mar 2016, 09:20
Interesser: Skydning og IT
Geografisk sted: Ølstykke
Has thanked: 28 times
Been thanked: 35 times

Re: [Besvare]Hvorfor driller min Ubiquiti USG - Det var en fejl på unifi controlleren!

Indlæg af Rednex » 20. maj 2019, 23:42

Kleth skrev:
20. maj 2019, 22:07
Godt tip om dnsmasq :thumbup:
Det var faktisk først for nyligt at jeg fandt ud af det med dnsmasq. Det skyldes muligvis at jeg har kørt Pi-Hole siden før de lavede deres egen (pihole-FTL), så tidligere SKULLE dnsmasq køre. Jeg håber at det er den primære årsag til mine problemer med opdateringer, men det må tiden vise.
Kleth skrev:
20. maj 2019, 22:07
Hvis jeg sætter controlleren til Pi-Hole som primær DNS og OpenDNS som sekundær DNS, så falder den vel direkte over OpenDNS såfremt Pi-Hole ikke svarer som DNS?!?
Den burde falde over på OpenDNS hvis Pi-Hole er nede, men jeg synes jeg har blandede oplevelser med den slags. Jeg ved ikke om Windows kører round-robin mellem primær og sekundær DNS, men jeg synes jeg har oplevet problemer med DNS selvom en af dem kører. Omvendt kan du nok heller ikke være sikker på at den altid vælger Pi-Hole selvom den er oppe. Det kommer nok i sidste ende an på dit OS.

Jeg kan i øvrigt anbefale 1.1.1.1 og 1.0.0.1 som upstream/backup DNS (se https://1.1.1.1). Det er CloudFlare der står bag.

VPN (IPSEC) har jeg sat op på min router (Ubiquiti EdgeRouter ER-4).

Besvar